Change to API services - include "internal_label"
Incident Report for Formstack
Resolved
This API change has been released as of 1:00PM Eastern time on October 22nd.
Posted Oct 22, 2024 - 13:17 EDT
Investigating
On Tuesday, October 22 we are releasing an update to the API that adds a new value, internal_label, to a few endpoints related to forms, fields, and submissions. If there is no internal label set on a field, null will be returned for this new value.

The following endpoints will now include internal_label:

GET /form/:id/field
GET /form/:id
GET /field/:id
GET /form/:id/submission (using parameter data=true)
GET /form/:id/partialSubmission (using parameter data=true)
GET /submission/:id (using parameter data=true)
GET /partialSubmission/:id (using parameter data=true)


The following endpoints will now accept internal_label:

PUT /field/:id
POST /form/:id/field

To learn more about the new Internal Labels feature, read more here:
https://help.formstack.com/s/article/Internal-Labels

For more information on how to use the Forms API, read more here:
https://developers.formstack.com/reference/api-overview
Posted Oct 22, 2024 - 10:42 EDT
This incident affected: Formstack Forms (Forms API).