Forms Admin App is Down
Incident Report for Formstack
Resolved
Engineers have monitored performance for the last hour and waving the green flag.
Posted Feb 17, 2025 - 16:40 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 17, 2025 - 16:39 EST
Monitoring
The engineers have identified the issue and resolved it. The database and web application traffic has been restored and all functions are back to normal. Most live forms were not affected, so consumers filling out forms and creating submissions were not interrupted. The Admin app was slowed down or non-functional for about 10-12 minutes from about 3:25 pm Eastern to 3:26 pm.
Posted Feb 17, 2025 - 15:58 EST
Identified
The issue has been identified and appear to be resolved.
Posted Feb 17, 2025 - 15:34 EST
Investigating
502 Bad Gateway is an error for all users logging in to the Forms Admin app.
Posted Feb 17, 2025 - 15:32 EST
This incident affected: Formstack Forms (Main Application).