New API Service Released! Submission Search across all forms
Incident Report for Formstack
Resolved
Resolving this notification
Posted Feb 16, 2025 - 16:41 EST
Monitoring
We are introducing a new search endpoint that allows you to search all forms in an account for specific submission values.

GET /api/v2/submission


The primary purpose of this API service is to support customers with GDPR data retention requests and similar. In the past, if an individual requested to be forgotten, searching each form for the submission data they provided (usually an email) was very time-consuming. This new service will allow searching for that attribute across all submission data in the account and provides a list of forms and submissions containing the value.

This service is limited to returning 10,000 submissions that match the search at any one time.
Posted Feb 14, 2025 - 10:18 EST
This incident affected: Formstack Forms (Forms API).