Forms API updated to add HTML property for V4 forms
Incident Report for Formstack
Resolved
This API change was released approximately 10:30AM Eastern time on Monday August 26th and we are not seeing any errors.
Posted Aug 26, 2024 - 12:14 EDT
Investigating
On Monday, August 26th, we are releasing a change to the Forms API. In the past, the GET /api/v2/form/{id}/html method always returned V3 HTML, regardless of the form version.

Requests using the API to retrieve form data, or specifically form HTML data, will now contain an extra property in its response if this form is V4. The property name is v4html and will contain the HTML data for a V4 form. The property 'html' will still default to return V3 HTML data even if the form is V4 for the time being.

This new property was added in two different endpoints, the GET /api/v2/form/{id} and GET /api/v2/form/{id}/html.

These changes also can be seen in the respective documentation pages.
/form/:id https://developers.formstack.com/reference/form-id-get
/form/:id/html https://developers.formstack.com/reference/form-id-html-get
Posted Aug 26, 2024 - 10:29 EDT
This incident affected: Formstack Forms (Forms API).