Form Renderer API updated to add setValues method
Incident Report for Formstack
Resolved
This API improvement has been deployed and is available now
Posted Aug 28, 2024 - 12:03 EDT
Investigating
We have modified the Live Form API to add two new features:

1. Added form.setValues method - to set the values of multiple fields at the same time.
This is structured after the field.setValue method that existed previously.
form.setValues will execute only one calculation and validation cycle making it a more efficient way to set the values of multiple fields at once.

Documentation: https://live-form-api.formstack.com/interfaces/IFormApi.html#setValues

2. Added a Promise return to the setValue(s) methods to allow you to check when the operation is complete.

Documentation: https://live-form-api.formstack.com/interfaces/IFieldApi.html#setValue

These features are now available in production and available for use on V4 forms.
Posted Aug 28, 2024 - 11:13 EDT
This incident affected: Formstack Forms (V4 Forms LiveForm API).