Errors on submissions / exports with signature fields (10/19 - 10/21)
Incident Report for Formstack
Resolved
The engineering team has released a change to PDF exports to continue the export even if the signature file is missing. This will allow customers to resume their business workflows for those submissions that were broken in the time we were having issues with signatures. Unfortunately, the missing signature files can not be recovered, so customers may need to request those forms be re-submitted for the full information to be available.

Now that the exports are fully supported again, feel free to re-run exports and email deliveries.
Posted Oct 21, 2024 - 16:43 EDT
Monitoring
We have identified the root cause of this issue and have resolved it for future submissions. In addition, engineers are working on a solution to enable exports for submissions with corrupted signature files. We will keep this incident open until that solution is in place. In the meantime, re-running exports (manual exports, scheduled exports, email delivery with PDF) will continue to fail.
Posted Oct 21, 2024 - 14:19 EDT
Identified
The engineering team has identified an issue where submissions with signature fields were failing to capture the signature file. Therefore, those submissions were created, but with a corrupt signature file. That missing signature file then prevents a PDF from being created in the area of an email delivery, a manual PDF export, and a scheduled PDF export.

According to our records, the signature problem started intermittently at approximately 11:00am Eastern on Saturday October 19th.

The submission issue has been solved at this time as of 10:50am Eastern today (Oct 21). This ensures that all new submissions coming in are working properly and adding a signature file.

Exports that failed in the past are not resolved at this time and the engineers are researching options.
Posted Oct 21, 2024 - 11:20 EDT
Investigating
We are seeing an increase in errors when customers create submission exports using PDF.
Posted Oct 21, 2024 - 09:45 EDT
This incident affected: Formstack Forms (Main Application).