Box.net File Upload integration intermittent outage
Incident Report for Formstack
Resolved
Formstack engineers have monitored the solution for the last few days and no further errors are being reported. All integrations are now fully restored.
Posted Apr 23, 2024 - 16:39 EDT
Monitoring
Formstack engineers have implemented a fix for this integrations issue. This fix will NOT restore integrations where the credentials are missing. However, re-authenticating the integrations will now be "sticky" and will keep the issue resolved. Therefore, customer intervention is required on affected forms. We apologize for the inconvenience this has caused and we continue to strive toward a more reliable and trustworthy experience within Formstack applications.
Posted Apr 19, 2024 - 11:50 EDT
Identified
The issue surrounding the Box.net integration credentials has been identified and the engineers are currently working on a fix. The expectation is to fix this release today (Friday April 19).
Posted Apr 19, 2024 - 10:07 EDT
Update
Engineers continue to investigate this issue. There are a few meaningful leads, but no conclusive evidence to determine a cause at this time.
Posted Apr 18, 2024 - 18:58 EDT
Investigating
The submit-action integration with Box.net is producing intermittent errors. The User will see an error like, "Unable to refresh access token". Reauthenticating the integration will solve the issue, but this solution may be temporary. If the integration authentication has expired, then submissions will be blocked on that form until reauthenticated. It is possible the integration will need to be reauthenticated multiple times until we resolve this issue.
Posted Apr 18, 2024 - 10:15 EDT
This incident affected: Formstack Forms - Third Party Integrations (Box.net Integration).