At approximately 3:45 pm (Eastern time) on Tuesday January 28, engineers released a change to the Forms SSO Prefill Mapping mechanism to make the data key case-insensitive for custom field mappings when information is coming from the SSO provider. the intention was to make the prefill mapping easier to match and require less precision from the SSO provider. However, it appears to have interrupted some existing prefill-mapping setups, so we have reverted this change (Effective 4:30 pm, Wednesday January 29) while we research another solution.
Posted Jan 29, 2025 - 16:57 EST
Identified
The issue has been identified and a possible fix has been deployed. Engineers are re-testing field prefill now to ensure the problem is resolved.
Posted Jan 29, 2025 - 16:44 EST
Investigating
When a form uses SSO in its Form Security Settings, a user can select a prefill mapping mechanism to pre-populate form fields from the SSO (Single Sign On) source. Some customers are experiencing this prefill mapping to be unreliable and some custom fields are getting un-mapped upon save. We are investigating the cause of this and will update when we have more news.
Posted Jan 29, 2025 - 16:08 EST
This incident affected: Formstack Forms (SSO Form Security).