The google sheets integration is operating normally
Posted Apr 03, 2025 - 17:45 EDT
Monitoring
We have identified a single form that is causing the influx of the Google Sheets integration requests, and we have isolated that form so it is not slowing others down. We expect other form integrations to move more quickly going forward.
Posted Apr 03, 2025 - 14:00 EDT
Identified
Engineers have identified the problem and are working on a solution. Submissions are still being sent to Google Sheets, and the process is still very slow. We are seeing some submissions taking as long as 5 minutes each.
Posted Apr 03, 2025 - 12:01 EDT
Investigating
Engineers have noticed that the integration queue for Google Sheets submissions integrations is processing very slowly this morning. They are looking into a solution and will update this page soon. No customer action is required at this time.
Posted Apr 03, 2025 - 10:23 EDT
This incident affected: Formstack Forms - Third Party Integrations (Google Sheets).